Car Engine Does Not Start Middletown NY

Find out what to do if you have a car that just will not start in Middletown. This article deals with that very problem. The Honest Mechanic gives some helpful advice to a car owner trying to get his 1992 Mercury Tracer Station Wagon running.

Local Companies

All Season Tire & Auto Center
(845) 783-2281
192 State Route 17M
Harriman, NY
Greg Rowe's Collision & Paint Center Inc.
(845) 692-3737
791 Route 211 East
Middletown, NY
Leifsigns Llc
(845) 561-1777
32 Cedar Ave
New Windsor, NY
Middletown Goodyear
(845) 343-6300
125 Dolson Avenue
Middletown, NY
Safelite Auto Glass
(888) 820-2558
500 N Galleria Dr
Middletown, NY
Advanced Automotive of New Windsor Inc
(845) 562-0346
2450 Rr 32
New Windsor, NY
Cherry Tire Service Inc
(845) 427-2112
952 Homestead Avenue
Maybrook, NY
Jim Hupka's Autobody Repair
(570) 491-2215, 001-2004
244 Tenth Street
Matamoras, PA
Monhagen Auto Repair
176-178 MONHAGEN AVE
Middletown, NY
Safelite Auto Glass
(888) 820-2558
1137 Route 17 M
Monroe, NY
Data Provided by:
  

Provided by:

Reader Question: I have a 1992 Mercury Tracer Station Wagon with a 1.9L engine. Last week, when I tried to start the car it would not start. Engine would turn over but would not fully start and when you turned the key off it started dieseling. That is bad key off and car still trying to run.

Well, I thought I had a timing problem. Car has 117,000 miles on it. I thought that the timing had jumped just enough to cause the problem. Therefore, I got a new timing belt and alternator belt and proceeded to put them on. When I got down to the timing belt, it looked OK and the timing marks were at the correct marks.

Now this started to worry me, I went ahead and put the new belts on because I did not know when they had been replaced I was not taking any chances. When I tried to start, the car with the new parts on I got the same thing, car still diesels and does not want to shut off.

I took the electronic ignition control module off, had it tested, and it did not pass the test so I bought a new ignition module and put it on.

You guessed it still dieseling and will not crank up and does not want to shut down when you turn the key off. 2 months ago, I put in new spark plugs and wires, last month I put in a new oxygen sensor.

It appears that I am getting gas because I pulled the clip off the fuel filter and pulled the line apart and got gas.

Any suggestions will be a great help.

I need to get this car up and running.

Thanks for your help.

Rodney

Hey Rodney,

You definitely have something weird going on here. I wonder if you are getting too much fuel to the engine, flooding the engine with raw fuel and the run on or dieseling is caused by this excess of fuel inside a hot cylinder? I would test the fuel pressure regulator
to see if you have too much fuel to the engine.

To read the full article, visit Myhonestmechanic.com