Car Engine Died Fulton NY

In this article the Honest Mechanic answers questions from a car owner with engine problems. This person’s car engine has died and he can’t seem to figure out why. Read on and find out what kind of advice this car owner gets so that if you’re ever stuck with a car with a dead engine in Fulton you’ll know just what to do.

Local Companies

Goodyear Auto Service Center
(315) 652-6673
8395 Oswego Road
Baldwinsville, NY
Napa Auto Parts
(315) 635-3961
64 E Genesee St
Baldwinsville, NY
Penn Power Systems
(315) 451-3840
7044 Interstate Island Rd
Syracuse, NY
Terry Scheirer
59 US Route 11
Central Square, NY
A Burdick Discount Transmission
(315) 676-2211
Pennellville, NY
Country Auto Service
(315) 695-2275
35 Evans Road
Pennellville, NY
Hudson & Mowins
(315) 635-5681, 001-2004
62 East Genesee Street
Baldwinsville, NY
Midas Auto Service Experts
(315) 458-6962
5453 S Bay Rd
Syracuse, NY
Rick Dumigan
722 N Main St
Central Square, NY
Moultons Auto & Truck Services
W Monroe, NY
Data Provided by:

Provided by:

Reader Question I have a 1991 Buick Regal w/3800 engine. Slight intermittent problem w/wanting to quit while driving over past couple of months, but today when I started it, it caught then immediately died. Now won't start at all - won't even try to fire. Turns over strong. Doesn't seem to have jumped time.

Code said cam sensor problem, so I replaced, but no luck.

I can hear the fuel pump like normal when I turn the key on, runs for couple secs, then quiet like normal. But the weird thing is when I'm done trying to start it, the pump will run for maybe 15 more seconds, plus maybe sounds a little more free-wheeling than normal.

I loosened the fuel line fitting at the engine. No fuel came out until I turned the key on, then fairly steady stream running from the fitting.

Could this be a weak fuel pump (replaced w/after market unit about 2 years ago)?

BTW, vehicle has always had an issue of dying at intersections intermittently - typically I just shift into neutral now.

Also, perpetual check engine light. If I remember the code has always been the cam sensor - I have replaced it before w/no change.

Also, oil leak somewhere above the CAM sensor, or front seal leak.

Also, would stall out right after filling up, so I replaced the fuel tank / canister purge valve about 2 weeks ago, which fixed the problem.

Also, had just put gas in it an driven it 100 miles before it died. Had been sitting maybe an hour, but wouldn't start even after completely cold.

Also, new after market injectors and pressure regulator about 2 years ago, cleaned tank, etc. (old gas issue).

Thanks for your help. Great advice from what I've seen.


Hey there Bob.

I would really like to know if you have spark at the spark plugs and if you have injector "pulse" before I really felt comfortable telling you to replace anything, but checking both of those items can be a little tricky without the proper tools.

SOOOOOOO, if you just want my best sitting behind my computer screen GUESS…..I would replace the crankshaft position sensor first and pray.

To read the full article, visit
Related Articles